#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<title>.+<\/title>"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque aliquam efficitur neque, at fringilla nunc condimentum quis. Aenean eros nibh, suscipit nec luctus nec, gravida sit amet arcu. Integer cursus tempor leo in pharetra. Ut accumsan hendrerit venenatis. Etiam tristique sed ipsum et pellentesque. <title>foo bar</title> In vitae turpis felis. Duis laoreet elit a diam tempor, nec pellentesque dui bibendum. Quisque pretium nulla vel venenatis varius. Nulla dapibus, augue sit amet ullamcorper suscipit, tortor nunc viverra tortor, ac ultricies ligula tellus vitae nibh. Fusce dapibus quis ante ut facilisis. Suspendisse laoreet pellentesque erat, ut hendrerit orci facilisis a. Suspendisse molestie vestibulum dolor, eu molestie nibh semper ut." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")