import re
regex = re.compile(r"<title>.+<\/title>")
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque aliquam efficitur neque, at fringilla nunc condimentum quis. Aenean eros nibh, suscipit nec luctus nec, gravida sit amet arcu. Integer cursus tempor leo in pharetra. Ut accumsan hendrerit venenatis. Etiam tristique sed ipsum et pellentesque. <title>foo bar</title> In vitae turpis felis. Duis laoreet elit a diam tempor, nec pellentesque dui bibendum. Quisque pretium nulla vel venenatis varius. Nulla dapibus, augue sit amet ullamcorper suscipit, tortor nunc viverra tortor, ac ultricies ligula tellus vitae nibh. Fusce dapibus quis ante ut facilisis. Suspendisse laoreet pellentesque erat, ut hendrerit orci facilisis a. Suspendisse molestie vestibulum dolor, eu molestie nibh semper ut.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")