$re = '/<!--{if(\s+\(?(\$[^\s!=]+)[^}]+)}-->/m';
$str = '<!--{if $projectdisplaymode != \'Widget\'}-->
<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != \'Widget\' )}-->
<!--{if $runnow == \'true\'}-->
<!--{if (isset($runnow ) && $runnow == \'true\' )}-->
<!--{if $showdelete == \'Yes\'}-->
<!--{if $average_rating_colorclass == \'progress0\'}-->
<!--{if ($percentage!="")}-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);