$re = '/\/.*?[\w:]+/m';
$str = '/home/local/path
/home/local/path.txt
/webroot/content/css3/remote/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);