re = /\/.*?[\w:]+/m
str = '/home/local/path
/home/local/path.txt
/webroot/content/css3/remote/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end