#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)'[^'\\]*(?:\\.[^'\\]*)*'(*SKIP)(?!)|"[^"\\]*(?:\\.[^"\\]*)*""
Local $sString = "header("Last-Modified: ".gmdate("D, d M Y H:i:s")." GMT");" & @CRLF & _
"$sql = "UPDATE $table_name SET" & @CRLF & _
"password = password('$newpass'), pchange = '1'" & @CRLF & _
"WHERE email = '$email'";" & @CRLF & _
"$var = '"' . $something . '"';" & @CRLF & _
"$msg = "<p><a href=\"login.html\">Login</a></p>";" & @CRLF & _
"echo "<label for=\"whatever\">LABEL</label><select class='".$style."'>";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")