$re = '/\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'(*SKIP)(?!)|"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"/m';
$str = 'header("Last-Modified: ".gmdate("D, d M Y H:i:s")." GMT");
$sql = "UPDATE $table_name SET
password = password(\'$newpass\'), pchange = \'1\'
WHERE email = \'$email\'";
$var = \'"\' . $something . \'"\';
$msg = "<p><a href=\\"login.html\\">Login</a></p>";
echo "<label for=\\"whatever\\">LABEL</label><select class=\'".$style."\'>";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);