const regex = /\d+\s*\.\s*((?:.+(?:\r\n?|\n))*?(?=[aA]\)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\s*\\.\\s*((?:.+(?:\\r\\n?|\\n))*?(?=[aA]\\)))', 'gm')
const str = `8. X-XIII asrlarda barpo etilgan inshootlar to‘g‘ri berilgan qatorni aniqlang.
1) Ismoil Somoniy maqbarasi, 2) Masjidi Kalon,
3) Namozgoh, 4) Minorayi Kalon, 5) Vobkent minorasi, 6) Ahmad Yassaviy maqbarasi, 7) Jarqo‘rg‘on minorasi, 8) Kaltaminor.
A) 1, 2, 3, 6, 7
B) 1, 3, 4, 5, 7
C) 1, 2, 4, 6, 8
D) 2, 3, 4, 6, 7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}