import re
regex = re.compile(r"\d+\s*\.\s*((?:.+(?:\r\n?|\n))*?(?=[aA]\)))", flags=re.MULTILINE)
test_str = ("8. X-XIII asrlarda barpo etilgan inshootlar to‘g‘ri berilgan qatorni aniqlang.\n"
"1) Ismoil Somoniy maqbarasi, 2) Masjidi Kalon,\n"
"3) Namozgoh, 4) Minorayi Kalon, 5) Vobkent minorasi, 6) Ahmad Yassaviy maqbarasi, 7) Jarqo‘rg‘on minorasi, 8) Kaltaminor.\n"
"A) 1, 2, 3, 6, 7\n"
"B) 1, 3, 4, 5, 7\n"
"C) 1, 2, 4, 6, 8\n"
"D) 2, 3, 4, 6, 7")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")