import re
regex = re.compile(r"<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\/faultstring>", flags=re.MULTILINE)
test_str = "<env:Envelope xmlns:env=\"http://schemas.xmlsoap.org/soap/envelope/\"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List \"Outage List2\" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1=\"http://service.admin.ws.five9.com/\"><listName xmlns:ns2=\"http://service.admin.ws.five9.com/\">Outage List2</listName><message>List \"Outage List2\" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")