#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxXi)# ./configure parser" & @CRLF & _
"" & @CRLF & _
"^(?:" & @CRLF & _
" (?:configuring[[:space:]]for[[:space:]](.+))" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" checking[[:space:]]" & @CRLF & _
" (?:" & @CRLF & _
" (?:build|host)" & @CRLF & _
" [[:space:]]system[[:space:]]type" & @CRLF & _
" |" & @CRLF & _
" how[[:space:]]to[[:space:]](.+?)" & @CRLF & _
" |" & @CRLF & _
" for[[:space:]](.+?)" & @CRLF & _
" |" & @CRLF & _
" whether[[:space:]](?:to[[:space:]])?(.+?)" & @CRLF & _
" )[\.]{3}" & @CRLF & _
" )" & @CRLF & _
" (?:" & @CRLF & _
" [[:space:]]+" & @CRLF & _
" (?:" & @CRLF & _
" $" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" (yes)" & @CRLF & _
" |" & @CRLF & _
" (no)" & @CRLF & _
" |" & @CRLF & _
" (?<!^)(.*)(?=$|\n)" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )?.*" & @CRLF & _
")$" & @CRLF & _
"" & @CRLF & _
"# ^(?:(?:configuring[[:space:]]for[[:space:]](.+))|(?:checking[[:space:]](?:(?:build|host)[[:space:]]system[[:space:]]type|how[[:space:]]to[[:space:]](.+?)|for[[:space:]](.+?)|whether[[:space:]](?:to[[:space:]])?(.+?))[\.]{3})(?:[[:space:]]+(?:$|(?:(yes)|(no)|(?<!^)(.*)(?=$|\n))))?.*)$"
Local $sString = "configuring for zsh 5.7.1-test-2" & @CRLF & _
"checking build system type... x86_64-apple-darwin17.7.0" & @CRLF & _
"checking host system type... x86_64-apple-darwin17.7.0" & @CRLF & _
"checking for gcc... gcc" & @CRLF & _
"checking whether the C compiler works... yes" & @CRLF & _
"checking for C compiler default output file name... a.out" & @CRLF & _
"checking for suffix of executables... " & @CRLF & _
"checking whether we are cross compiling... no" & @CRLF & _
"checking for suffix of object files... o" & @CRLF & _
"checking whether we are using the GNU C compiler... yes" & @CRLF & _
"checking whether gcc accepts -g... yes" & @CRLF & _
"checking for gcc option to accept ISO C89... none needed" & @CRLF & _
"checking for special C compiler options needed for large files... no" & @CRLF & _
"checking for _FILE_OFFSET_BITS value needed for large files... no" & @CRLF & _
"checking how to run the C preprocessor... gcc -E" & @CRLF & _
"checking for an ANSI C-conforming const... yes" & @CRLF & _
"checking for gcc option to accept ANSI C... " & @CRLF & _
"checking whether to use prototypes... yes" & @CRLF & _
"checking for grep that handles long lines and -e... /usr/local/bin/ggrep" & @CRLF & _
"checking for egrep... /usr/local/bin/ggrep -E" & @CRLF & _
"checking for ANSI C header files... yes" & @CRLF & _
"checking for sys/types.h... yes" & @CRLF & _
"checking for sys/stat.h... yes" & @CRLF & _
"checking for stdlib.h... yes" & @CRLF & _
"checking for string.h... yes" & @CRLF & _
"checking for memory.h... yes" & @CRLF & _
"checking for strings.h... yes" & @CRLF & _
"checking for inttypes.h... yes" & @CRLF & _
"checking for stdint.h... yes" & @CRLF & _
"checking for unistd.h... yes" & @CRLF & _
"checking for size_t... yes" & @CRLF & _
"checking for working alloca.h... yes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")