package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d\s*){9}\d$`)
var str = `4874526395
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}