package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w-\.]+@([\w-]+\.)+[\w-]{2,4}$`)
var str = `kaibrahima32@gmail.com
pape@g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}