package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9-]+=[a-zA-Z0-9-]+$`)
var str = `a=b
1=1
a-b=c-d
a=b
foo=bar
ba=r=b=az
b = z
a-b=c - d
te:st=st:ring`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}