// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9-]+=[a-zA-Z0-9-]+$").unwrap();
let string = "a=b
1=1
a-b=c-d
a=b
foo=bar
ba=r=b=az
b = z
a-b=c - d
te:st=st:ring";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}