using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"DATA.tracking.user = (.*?)\}";
string input = @"<script>
DATA.tracking.user = { age: ""19"", name: ""John doe"" } // This works
DATA.tracking.user = {
age: ""19"",
name: ""John doe""
} // This does not works
</script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}