re = /DATA.tracking.user = (.*?)\}/m
str = '<script>
DATA.tracking.user = { age: "19", name: "John doe" } // This works
DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end