package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\s*-\s*\d)`)
var str = `argentina #1-0~won~
draw #0-0~won~
draw#0- 0~won~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}