$re = '/(\d\s*-\s*\d)/m';
$str = 'argentina #1-0~won~
draw #0-0~won~
draw#0- 0~won~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);