use strict;
my $str = '.a.b.1.2.';
my $regex = qr/(?<!\d(?=\.\d))\./mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";