$re = '/(?<!\d(?=\.\d))\./m';
$str = '.a.b.1.2.';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;