import re
regex = re.compile(r"^(http://|https://|http://www\.|https://www\.|www\.)?(www\.(twanda))?(([\w\-]+)?\.?(twanda|))(\.ch|\.com)(:\d+)?/.+$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://flohmarkt-zug.twanda.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://flohmarkt-zug.twanda.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.flohmarkt-zug.ch/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.flohmarkt-zug.ch:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://flohmarkt-zug.twanda.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://flohmarkt-zug.twanda.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.flohmarkt-zug.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"https://www.flohmarkt-zug.com:8069/store/apps/details?id=com.skgames.trafficracer%22\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)