$re = '/^http:\/\/(?!www\.).*$/m';
$str = 'http://www.host.com
http://host.com
www.host.com
host.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);