re = /^http:\/\/(?!www\.).*$/m
str = 'http://www.host.com
http://host.com
www.host.com
host.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end