#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(?<=") # A filename is after a double quote char" & @CRLF & _
"(?:[^"\/]+\/)+ # the path is one or more words separated with a slash" & @CRLF & _
"[^"\/]+ # The filename (not the path) can be anything but a double quote char and a slash" & @CRLF & _
"[.]\w+ # The extension cannot have space and have the form of .foobar" & @CRLF & _
"(?:") # A filename end with a double quote char"
Local $sString = "example 1: soundSet = { name = "bus_modern", horn = "vehicle/truck_modern/horn.wav" }" & @CRLF & _
"example 2: id = "vehicle/bus/citaro/lod_0_w2.msh"," & @CRLF & _
"example 3: "vehicle/bus/berkhof_duvedec/berkhof_duvedec_lod_0_w2.msh", "vehicle/bus/berkhof_duvedec/berkhof_duvedec_lod_0_w3.msh", " & @CRLF & _
"id = "vehicle/train/BR 78_Body.grp""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")