# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?<=") # A filename is after a double quote char
(?:[^"\/]+\/)+ # the path is one or more words separated with a slash
[^"\/]+ # The filename (not the path) can be anything but a double quote char and a slash
[.]\w+ # The extension cannot have space and have the form of .foobar
(?:") # A filename end with a double quote char
"""
test_str = ("example 1: soundSet = { name = \"bus_modern\", horn = \"vehicle/truck_modern/horn.wav\" }\n"
"example 2: id = \"vehicle/bus/citaro/lod_0_w2.msh\",\n"
"example 3: \"vehicle/bus/berkhof_duvedec/berkhof_duvedec_lod_0_w2.msh\", \"vehicle/bus/berkhof_duvedec/berkhof_duvedec_lod_0_w3.msh\", \n"
"id = \"vehicle/train/BR 78_Body.grp\"")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.