package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`is (\w*)`)
var str = `Jame is sleeping but pretend that is "studying"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}