const regex = /[\w\s]+?(?=O)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\\s]+?(?=O)', '')
const str = `T071108452T 42D896D5O 3587O`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}