$re = '/[\w\s]+?(?=O)/';
$str = 'T071108452T 42D896D5O 3587O';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);