const regex = /^0[1-9](?=\d* \d+$)[ \d]{9,11}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0[1-9](?=\\d* \\d+$)[ \\d]{9,11}$', 'gm')
const str = `012345678 912
01 2345678091
0132345678091`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}