re = /^0[1-9](?=\d* \d+$)[ \d]{9,11}$/m
str = '012345678 912
01 2345678091
0132345678091'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end