$re = '/(?<=&)m=[^ ]*\&p=[^& ]*/';
$str = 'index.html?cr=33&m=prod&p=ded';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);