package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*,\s*`)
var str = `here is some text
here is some other text,
here is some different text, followed by some text
here is some other text,
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}