$re = '/.*,\s*/';
$str = 'here is some text
here is some other text,
here is some different text, followed by some text
here is some other text,
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);