package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`select\s(.*)\sfrom(.*)\s(where (.*))?\s*;`)
var str = `select a.a,b.b,c from a,b where a.a = b.a;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}