re = /select\s(.*)\sfrom(.*)\s(where (.*))?\s*;/
str = 'select a.a,b.b,c from a,b where a.a = b.a;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end