using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(part\d+_add)\([\s\S]*?\)$";
string input = @"part101_add(
name = ""part101-1"",
dev2_serial = ""dev_l622_01"",
serial_port = ""/dev/tty-part101-1"",
yok_serial = ""YT8388""
)
yok_tar_add(""YT8388"", None)
part2_add(
name = ""(part2-1)"",
serial_number = ""SERIALNUMBER"",
serial_port = ""/dev/tty-part2-1"",
yok_serial = ""YT03044"",
yok_port_board = ""N""
)
yok_tar_add(""YT03044"", None)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}