# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^(part\d+_add)\([\s\S]*?\)$"
test_str = ("part101_add(\n"
" name = \"part101-1\",\n"
" dev2_serial = \"dev_l622_01\",\n"
" serial_port = \"/dev/tty-part101-1\",\n"
" yok_serial = \"YT8388\"\n"
")\n"
"yok_tar_add(\"YT8388\", None)\n"
"part2_add(\n"
" name = \"(part2-1)\",\n"
" serial_number = \"SERIALNUMBER\",\n"
" serial_port = \"/dev/tty-part2-1\",\n"
" yok_serial = \"YT03044\",\n"
" yok_port_board = \"N\"\n"
")\n"
"yok_tar_add(\"YT03044\", None)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.