$re = '/(?=(:\w+:))/';
$str = '"test :candidate: test"
"test :candidate: test:"
"test :candidate:_test:"
"test :candidate::test"
"test ::candidate: test"
"test :candidate_: :candidate: test"
"test :candidate_:candidate: test"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);