re = /(?=(:\w+:))/
str = '"test :candidate: test"
"test :candidate: test:"
"test :candidate:_test:"
"test :candidate::test"
"test ::candidate: test"
"test :candidate_: :candidate: test"
"test :candidate_:candidate: test"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end