$re = '/\w(?:[\w\'-]*\w)?/';
$str = 'Hello, this is a test string with hyphenated-words. D\'oh! \'blah\' --hi-hi--';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);