re = /\w(?:[\w'-]*\w)?/
str = 'Hello, this is a test string with hyphenated-words. D\'oh! \'blah\' --hi-hi--'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end