const regex = /;(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(';(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)', 'gim')
const str = `asbas;"asd;";asd;asdadasd;"asd;adsas"`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);