re = /;(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)/im
str = 'asbas;"asd;";asd;asdadasd;"asd;adsas"'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result