package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\,\s]*)(Ste |Ste. )`)
var str = `12 Watershore Circle
825 Stewart Street
820 N Lincoln Way
9235 Bella Vista Way
P.O. Box 4438
9936 Stone Oak Way
599 Hamstead Drive
3941 Park Drive Ste 20 #147
3609 Bradshaw RD,ste H #107
7909 Walerga Road, Ste. 112, PMB 108
Options I've tried for what I want:
([\,\s]*)(Ste |Ste. )
([\,\s]+)(Ste |Ste. )
(\,*[\W]Ste[\W]|\,*[\W]Ste\.[\W])
What the live results on my webpage seem to think these mean:
(\,*[\w]Ste[\w]|\,*[\w]Ste\.[\w])
or
([\,\s]*)(Ste|Ste\.)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}