import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\,\\s]*)(Ste |Ste. )";
final String string = "12 Watershore Circle\n"
+ "825 Stewart Street\n"
+ "820 N Lincoln Way\n"
+ "9235 Bella Vista Way\n"
+ "P.O. Box 4438\n"
+ "9936 Stone Oak Way\n"
+ "599 Hamstead Drive\n"
+ "3941 Park Drive Ste 20 #147\n"
+ "3609 Bradshaw RD,ste H #107\n"
+ "7909 Walerga Road, Ste. 112, PMB 108\n\n\n"
+ "Options I've tried for what I want:\n"
+ "([\\,\\s]*)(Ste |Ste. )\n"
+ "([\\,\\s]+)(Ste |Ste. )\n"
+ "(\\,*[\\W]Ste[\\W]|\\,*[\\W]Ste\\.[\\W])\n\n"
+ "What the live results on my webpage seem to think these mean:\n"
+ "(\\,*[\\w]Ste[\\w]|\\,*[\\w]Ste\\.[\\w])\n"
+ "or\n"
+ "([\\,\\s]*)(Ste|Ste\\.)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}