import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(zzdel\\s+)(from\\s+)([^\\.]+)\\.([^\\s]+\\s)([^\\s]+)\\n(INNER\\s+)(JOIN\\s+)([^\\.]+)\\.(T001\\s+)(t0\\s+)(on\\s+)(t0\\.mandt\\s+)(=\\s+)([^\\.]+)\\.(mandt\\s+)";
final String string = "from SPP01.AUFM t\n\n"
+ "'' zzdel\n"
+ "from LP101.AFRU afru\n"
+ "INNER JOIN SPP01.T001 t0 on t0.mandt = t.mandt\n"
+ "INNER JOIN SPP01.BSEG on x=y\n\n\n"
+ "from LP101.AFRU afru\n"
+ "INNER JOIN SPP01.T001 t0 on t0.mandt = t.mandt\n\n"
+ "INNER JOIN SPP01.T001 t0 on t0.mandt=t.mandt\n"
+ "INNER JOIN SPP01.T001 t0 on t0.mandt = t.mandt\n\n"
+ "(zzdel\\s+)\n"
+ "(from\\s+)([^\\.]+)\\.([^\\s]+\\s)([^\\s]+)\n"
+ "(INNER\\s+)(JOIN\\s+)([^\\.]+)\\.(T001\\s+)(t0\\s+)(on\\s+)(t0\\.mandt\\s+)(=\\s+)([^\\.]+)\\.(mandt\\s+)\n\n"
+ "(INNER\\s+)(JOIN\\s+)([^\\.]+)\\.([^\\.]+)(on\\s)([^\\.]+)(=)([^\\s]+)\n"
+ "\\1\\2\\.\\3\\4\\nINNER JOIN \\2\\.T001 t0 on t0\\.mandt =\\4\\.mandt";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}