import re
regex = re.compile(r"(zzdel\s+)(from\s+)([^\.]+)\.([^\s]+\s)([^\s]+)\n(INNER\s+)(JOIN\s+)([^\.]+)\.(T001\s+)(t0\s+)(on\s+)(t0\.mandt\s+)(=\s+)([^\.]+)\.(mandt\s+)")
test_str = ("from SPP01.AUFM t\n\n"
"'' zzdel\n"
"from LP101.AFRU afru\n"
"INNER JOIN SPP01.T001 t0 on t0.mandt = t.mandt\n"
"INNER JOIN SPP01.BSEG on x=y\n\n\n"
"from LP101.AFRU afru\n"
"INNER JOIN SPP01.T001 t0 on t0.mandt = t.mandt\n\n"
"INNER JOIN SPP01.T001 t0 on t0.mandt=t.mandt\n"
"INNER JOIN SPP01.T001 t0 on t0.mandt = t.mandt\n\n"
"(zzdel\\s+)\n"
"(from\\s+)([^\\.]+)\\.([^\\s]+\\s)([^\\s]+)\n"
"(INNER\\s+)(JOIN\\s+)([^\\.]+)\\.(T001\\s+)(t0\\s+)(on\\s+)(t0\\.mandt\\s+)(=\\s+)([^\\.]+)\\.(mandt\\s+)\n\n"
"(INNER\\s+)(JOIN\\s+)([^\\.]+)\\.([^\\.]+)(on\\s)([^\\.]+)(=)([^\\s]+)\n"
"\\1\\2\\.\\3\\4\\nINNER JOIN \\2\\.T001 t0 on t0\\.mandt =\\4\\.mandt")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")