$re = '/^(?!.*[azAZ]).*$/mi';
$str = 'Alison
Alison.
Alizon
Alizon.
Amada
Amada.
Amanda
Amanda.
.Amanda
Ami
Ami.
.Ami.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);