re = /^(?!.*[azAZ]).*$/mi
str = 'Alison
Alison.
Alizon
Alizon.
Amada
Amada.
Amanda
Amanda.
.Amanda
Ami
Ami.
.Ami.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end